Boost your productivity with Excel:

- Discover useful timesaving features
- Master data entry shortcuts
- Use powerful functions for processing data
- Create pivot tables for insightful data analysis
- Get clever with What-if and Goal-seek
- Use graphs & charts to see the whole picture
- Learn to debug formulas to find errors
- Work with large spreadsheets

Whether you’ve been using Excel for years and never gone beyond the basics, or are just entering the world of spreadsheets, this book will quickly supercharge your Excel skills. Save hours by using the quick tips for data entry, and get more out of Excel by exploring the powerful tools on offer for data analysis – all in easy steps!

£5.99 UK / $8.99 US
Sean McManus

100 TOP TIPS

Microsoft Excel

- Supercharge your Excel skills
- Learn more from your data
- Boost your productivity

in easy steps
Contents

1 Entering data with Auto Fill .......................................................... 5
2 Filling to match the neighboring column .................................... 6
3 Using Flash Fill ............................................................................ 7
4 Adjusting column widths and row heights ..................................... 8
5 Inserting multiple rows or columns ............................................. 9
6 Managing large spreadsheets ...................................................... 10
7 Forcing valid data entry ............................................................. 11
8 Adding a drop-down menu ........................................................ 12
9 Creating custom validation ........................................................ 13
10 Removing duplicates ................................................................. 14
11 Highlighting duplicates ............................................................. 15
12 Using advanced paste options .................................................. 16
13 Expanding the clipboard .......................................................... 17
14 Moving data .............................................................................. 18
15 Entering formulas ...................................................................... 19
16 Understanding formula symbols ............................................... 20
17 Finding the highest/lowest value in a range ............................... 21
18 Ranking data items ................................................................... 22
19 Finding an item by its ranking using LARGE .............................. 23
20 Finding averages ......................................................................... 24
21 Sorting data .............................................................................. 25
22 Using filters ............................................................................... 26
23 Using IF for cell contents .......................................................... 27
24 Combining IF functions ............................................................. 28
25 Totaling up values with SUM ..................................................... 29
26 Choosing values to sum with SUMIF ......................................... 30
27 Using several sum criteria with SUMIFS .................................... 31
28 Using cumulative sums ............................................................. 32
29 Using SUMPRODUCT .................................................................. 33
30 Counting cells ........................................................................... 34
31 Using more count criteria ........................................................ 35
32 Using wildcards .......................................................................... 36
33 Grouping data ........................................................................... 37
34 Calculating subtotals ............................................................... 38
35 Using subtotals ........................................................................... 39
36 Copying visible data only ........................................................... 40
37 Naming ranges ........................................................................... 41
38 Using the Name Manager .......................................................... 42
39 Using VLOOKUP ......................................................................... 43
40 Using HLOOKUP ......................................................................... 44
41 Finding data with MATCH .......................................................... 45
42 Using the INDEX function ......................................................... 46
43 Using the CHOOSE function ...................................................... 47
44 Rounding data values ............................................................... 48
45 Using advanced rounding functions ......................................... 49
46 Calculating with dates ............................................................... 50
47 Making dates and breaking them down .................................... 51
48 Creating custom date formats .................................................. 52
49 Using multiple lines of text in cells ....................................... 53
50 Cleaning your text .................................................................... 54
51 Joining text from different cells .......................................................... 55
52 Getting the length of a piece of text ............................................... 56
53 Searching in text ........................................................................... 57
54 Extracting pieces of text ................................................................ 58
55 Splitting first and last names .............................................................. 59
56 Splitting text across columns .............................................................. 60
57 Replacing text in a cell ..................................................................... 61
58 Counting the number of words in a cell .......................................... 62
59 Counting occurrences of a word or phrase ..................................... 63
60 Debugging: Tracing precedents ......................................................... 64
61 Debugging: Tracing dependents ........................................................ 65
62 Debugging: Evaluating formulas ....................................................... 66
63 Using the Watch Window ................................................................. 67
64 Adding simple conditional formatting .......................................... 68
65 Adding advanced conditional formatting ..................................... 69
66 Creating new rules for conditional formatting ............................... 70
67 Managing conditional formatting .................................................... 71
68 Visualizing your data ....................................................................... 72
69 Using Quick Analysis ..................................................................... 73
70 Using What-If? scenarios ................................................................. 74
71 Using data tables ............................................................................. 76
72 Modeling two formulas in a data table .......................................... 78
73 Using two-dimensional data tables .................................................. 79
74 Using Goal Seek ............................................................................ 80
75 Preparing data for a pivot table ......................................................... 81
76 Creating a pivot table ..................................................................... 82
77 Deeper analysis with pivot tables ..................................................... 84
78 Using averages and counts in pivot tables ..................................... 85
79 Calculating percentages in pivot tables ......................................... 86
80 Using slicers ................................................................................... 87
81 Creating a pivot chart ..................................................................... 88
82 Tracing totals back to data ............................................................... 89
83 Refreshing a pivot table .................................................................. 90
84 Inserting a table ............................................................................... 91
85 Adding totals to a table .................................................................. 92
86 Formatting your table ..................................................................... 93
87 Setting (and clearing) a Print Area .................................................. 94
88 Printing to fit the page or across multiple pages ............................. 95
89 Adding a page header ..................................................................... 96
90 Adding a watermark ....................................................................... 97
91 Choosing cells to leave unlocked ..................................................... 98
92 Hiding formulas in cells .................................................................. 99
93 Password protecting ranges ............................................................. 100
94 Protecting the worksheet ................................................................. 101
95 Protecting the workbook ................................................................. 102
96 Protecting Excel files ..................................................................... 103
97 Data entry shortcuts ....................................................................... 104
98 Formatting shortcuts ...................................................................... 106
99 Navigation shortcuts ....................................................................... 107
100 Selection shortcuts ....................................................................... 108
Entering data with Auto Fill

If you’re typing in data that has a pattern to it, Excel can complete the pattern for you. You can use this for number sequences, times, and dates.

1. Enter the start of the sequence into two cells. If it’s a number sequence, you’ll need to enter at least two numbers. For times and dates, Excel can use just one. For alternate months (January, March, etc.), you’d enter the first two to show the pattern.

2. Highlight the cells containing your data.

3. Click the Fill handle. It’s a tiny dot in the bottom right of the selected area. Your cursor becomes a small black cross when you hover over it.

4. Drag the mouse to cover the area you want to fill. In the example shown here, you’d drag down. As you drag, you’ll see the value that’s being added shown next to your cursor.

5. Click the Auto Fill Options menu that appears beside your cursor to find options for the fill, including Copy, which fills each cell with the data you’ve selected. You can also fill weekdays, days, months, or years from dates. Try putting 31-Jan in the first box, then autofilling months to get the last day of each month.

6. Even quicker: If you just want a sequence of numbers going up by 1, enter the first number, select the cell and hold down Ctrl while you drag the Fill handle.
Filling to match the neighboring column

There’s an even quicker way to autofill a range so it matches the size of the neighboring columns.

1. Enter the first two data items in the sequence you want to use. For example, if you want to add years starting at 2025 and want to increase by 1 each time, enter 2025 and 2026 into two cells.

2. Highlight both cells containing the data items you just entered.

3. Double-click the Fill handle in the bottom right of the selected area.

4. Your data column is automatically filled to match the size of the neighboring columns. In my example, the autofill extends to where the data ends in the third column, even though the nearest column is shorter.
Using Flash Fill

Introduced in Excel 2013, Flash Fill recognizes patterns in data based on neighboring cells. It’s much more sophisticated than Auto Fill. You can use it, for example, to reformat text and split or combine data. Here’s an example.

1. You might have a list of names, with the first name and last name combined. For the first row, type the first and second names into the next cells. This is how you teach Excel the pattern to copy.

<table>
<thead>
<tr>
<th>Name</th>
<th>First Name</th>
<th>Surname</th>
</tr>
</thead>
<tbody>
<tr>
<td>Murphy Slaw</td>
<td>Murphy</td>
<td>Slaw</td>
</tr>
<tr>
<td>Bob Sled</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Phil Space</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dave Triffids</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gladys Working</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2. Position your cursor in the empty first name cell for the second name.

3. Press Ctrl + E or click the Flash Fill button on the ribbon. Find it by clicking the Data tab, then looking in the Data Tools.

4. The first name column is then automatically filled out for you. Check the results look okay, and then do the same for the last name column.
Adjusting column widths and row heights

Here are some tips for adjusting the width of columns. Similar ideas apply to rows.

1. To adjust the width of a column, click and drag the line to the right of its letter above the column. Here, I’m adjusting the width of column C.

2. To make the column width snap to the width of the content in the column, double-click this same dividing line above the column, on its right.

3. You can select several columns and adjust them at the same time, making them equal width, or making them all snap to their content width. To select a column, click its letter. Click and drag on the letters to select multiple columns, or use Ctrl + click to select columns that aren’t adjacent.

4. You might want to set the column width to a particular cell in the column, rather than the widest cell. Perhaps one cell contains a title that you’re happy to run into other cells. Select the cell you want to adjust the width to, go to Format in the Cells group of the Home tab, and select AutoFit Column Width.
Inserting multiple rows or columns

I’ll show you how to quickly insert multiple rows. You can use a similar technique to insert columns.

1. Click the number of the row where you want to insert above, and drag down for as many rows as you want to insert. For the example here, I want to insert three rows above row 4.

2. Click Insert in the Cells group of the Home tab. You could alternatively use Ctrl with the plus symbol (+). You can use the + key on your number keypad or add Shift to the key combination to use the key on the main keyboard.

3. If you’re inserting a row to copy another row into it, you can save time by copying the row first. When you insert, your copied row will be pasted into the new row(s).
Managing large spreadsheets

There are several techniques that can help you to manage large spreadsheets.

1. On the View tab, click New Window to see your worksheet in another window at the same time. You can scroll around in the windows independently, but it’s just two views of the same document. Any changes you make will be visible in both windows. Use Arrange All on the View tab to organize your windows side by side.

2. Keep column and/or row headings in view when you scroll. Also on the View tab, Freeze Panes can keep the top row or first column in view. You can freeze both by selecting the cell that is underneath the column heading and to the right of the row heading that you want to keep, and then choosing Freeze Panes. Using this approach, you can freeze several rows or columns.

3. Focus on what’s important by hiding rows and columns you don’t need right now. Select the rows or columns (click and drag on their letters or numbers in the margin), and choose Hide Rows or Hide Columns. These options are on the Home tab, in the Editing group, under the Format menu.
Forcing valid data entry

To improve data quality, you can validate data as it is entered into the spreadsheet.

1. Select the cells you want to apply validation to.

2. Click Data Validation on the Data tab of the ribbon. The Data Validation options open.

3. In the Allow menu, you can choose to allow any value (the default), whole numbers, decimals, dates, times, or text of a certain length. You can also define custom validation (see Tip 9) or use a list of valid data items (see Tip 8).

4. In the Data menu, you can choose a sequence of valid values (between), minimum and/or maximum values, or a sequence of invalid values (not between). Use the boxes below to enter the start and end dates, or minimum and maximum numbers. Use the Input Message tab to give users instructions on entering valid data. Instructions are shown when users select the cell.
Adding a drop-down menu

You can ensure data is valid and speed up its entry by putting a drop-down menu in a cell. This is one of the data validation options.

1. Select the cell(s) where you want to use the menu.

2. Click Data Validation on the Data tab of the ribbon to open the Data Validation options. There’s a shortcut: press ALT, D, and L one at a time.

3. In the Allow drop-down menu, choose List.

4. In the Source box, type the menu items, separated by a comma. Click OK.

5. If you prefer, you can use data that’s in a spreadsheet row, column, or named range (see p.41). In that case, enter an = sign followed by the name in the Source box, or enter = there and then select the menu items on the spreadsheet using the mouse. It’s easy to edit your menu later by simply editing those cells.

6. When you select one of the cells, a menu will appear so you can select the data you’d like to enter in that cell.
Creating custom validation

You can write your own validation rules. Select the cell(s) you want to validate and go to the Data Validation options (see Tip 7). Select Custom in the Allow menu. In the Formula box, enter a formula that gives a result of TRUE or FALSE. Here are some examples to validate cell J8:

- **Must start with text “CPC”**. \(=\text{COUNTIF}(J8, \text{"CPC"})=1\)
- **Length must be 3**. \(=\text{LEN}(J8)=3\)
- **Must be a number**. \(=\text{ISNUMBER}(J8)\)
- **First character must be a number**. The LEFT function is used to extract the character, and ISNUMBER is used to test whether it is a number. The VALUE function is required because in a data item like “UK-52”, the 52 would otherwise be treated as text. \(=\text{ISNUMBER}((\text{VALUE})(\text{LEFT}(J8,1)))\)
- **Last character must not be a number**. To see whether a character is not a number, we can check whether it is a number, and then wrap it in the NOT function to reverse the result. \(=\text{NOT}(\text{ISNUMBER}((\text{VALUE})(\text{RIGHT}(J8,1))))\)
- **Must be unique in column J**. This shows an error if the same data has already been entered in the same column. \(=\text{COUNTIF}(J:J, J8)<=1\)
- **Must be odd**. \(=\text{ISODD}(J8)\). ISEVEN can be used, too.

To allow multiple options, join them with OR, like this example, which allows data of 3 or 5 characters to be valid:

\(=\text{OR}(\text{LEN}(J8)=3, \text{LEN}(J8)=5)\)

To enforce multiple validation rules, use AND, like this example, which requires a 3-character code starting with A:

\(=\text{AND}(\text{LEN}(J8)=3, \text{COUNTIF}(J8, \text{"A"})=1)\)
Removing duplicates

You can remove duplicated data in a spreadsheet, which can easily happen if data such as mailing list information is combined from multiple sources.

1. Click in your data so Excel can find it.

2. Click Remove Duplicates on the Data tab of the ribbon. You’ll find it in the Data Tools group.

3. Select the columns that you want to check for duplicate entries. It’s safest to keep them all selected. If you just selected the First Name and Last Name (for example), two different people who share a name would be identified as duplicates, even though they have different addresses. One of them would be automatically deleted. This doesn’t happen if you select the address fields as well.

4. Click OK. Beware, though, as that might delete rows from your spreadsheet. Use Undo immediately to bring them back if you made a mistake.
TOP TIPS

Boost your productivity with Excel:

- Discover useful timesaving features
- Master data entry shortcuts
- Use powerful functions for processing data
- Create pivot tables for insightful data analysis
- Get clever with What-if and Goal-seek
- Use graphs & charts to see the whole picture
- Learn to debug formulas to find errors
- Work with large spreadsheets

Whether you've been using Excel for years and never gone beyond the basics, or are just entering the world of spreadsheets, this book will quickly supercharge your Excel skills. Save hours by using the quick tips for data entry, and get more out of Excel by exploring the powerful tools on offer for data analysis – all in easy steps!

£5.99 UK / $8.99 US